Pular para o conteúdo principal

Postagens

Dr. Planilha: Como Ocultar Erros em uma Fórmula do #Excel #dica (versão 2)

Há algum tempo atrás postei uma dica de como resolver esse problema utilizando as funções ÉERROS() e SE() (veja aqui). Funciona muito bem, mas se você procura algo mais simples de escrever e ler, a função SEERRO() pode ser uma alternativa mais interessante.

Antes de mais nada, vejamos qual a sintaxe dessa função:

SEERRO(valor; valor_se_erro)

Ao que se pode perceber imediatamente é que seu funcionamento é muito simples, basicamente ela implementa a solução que apresentei no artigo anterior, com a diferença de termos apenas uma função e dois parâmetros.

O parâmetro "valor" deverá ser preenchido com a fórmula que você pretende mostrar na célula, por exemplo: A1/A2.

O parâmetro "valor_se_erro" é o que você irá preencher na célula, caso sua fórmula resulte em um erro, como em uma divisão por zero. Em nosso exemplo eu poderia colocar o valor 0 (zero).

A função preenchida ficaria assim:

=SEERRO(A1/A2;0)

Ou se eu quisesse mostrar uma mensagem alertando do erro:

=SEERRO(A1/…
Postagens recentes

Dr. Planilha: Como calcular a idade completa de uma pessoa em anos, meses e dias com a função DATADIF do #Excel

Pesquisando hoje sobre uma função "escondida" do Excel resolvi fazer uma postagem rápida mostrando como calcular uma idade completa, com anos, meses e dias. Aproveito para apresentar essa função que não consta na lista das funções do Excel e muitas pessoas não conhecem, mas que pode ser bem útil no dia-a-dia para trabalhar com datas.

Como exemplo para entendermos melhor a função DATADIF, vou calcular minha idade completa na data de hoje. Considerando minha data de nascimento como data de início e a data de hoje (05/07/2016) como data fim, teríamos o seguinte resultado: 38 anos, 7 meses e 5 dias.

Como Consolidar Duas Planlhas em Uma com PROCV no #Excel. #dica

Acho que já disse isso antes, mas não custa repetir: o PROCV é uma das funções mais importantes e úteis para se usar em planilhas, sejam elas do Excel, Calc ou Google Spreadsheets, pois ambos implementam funções similares.

Nesta dica vamos resolver dois tipos de problemas comuns onde o PROCV tem especial importância. O primeiro problema é integrar em uma única planilha, informações que estão pulverizadas em duas ou mais planilhas. O outro problema consiste em comparar dados provenientes de duas planilhas diferentes para identificar se são iguais ou não.

O exemplo em questão foi inspirado em um problema proposto pelo amigo @marcioalmartins, embora esteja um pouco modificado e em escala muito menor, tanto de volume de dados, quanto em complexidade das tabelas. Mesmo em pequena escala, creio que será possível passar uma boa noção de como usar essa versátil função chamada PROCV para resolver situações deste tipo.

Vejamos a seguir como serão construídas as planilhas de nosso problema exem…

Mudança no sistema de comentários do blog.

Amigos leitores do blog,

O volume de comentários no blog está praticamente inadministrável... rs rs rs. Mas não estou reclamando, pelo contrário, esse volume crescente de acessos e interação através dos comentários é o combustível que mantém esse blog funcionando.

O problema é que não estou conseguindo gerir os comentários mais através do sistema do próprio blog, então, a partir de hoje, farei um teste com um novo recurso do blogger que integra os comentários do blog com o Google Plus.

Um grande abraço do Dr. Planilha!

Dr. Planilha: Como colar em várias planilhas ao mesmo tempo no #Excel

Não raramente precisamos copiar o conteúdo de uma planilha para várias outras de uma mesma pasta do Excel. Quando temos duas ou três planilhas, não há sofrimento algum em navegar individualmente entre elas para pressionar CTRL+V na célula desejada, no entanto, se tivermos várias planilhas, isso pode ser um pouco cansativo e até dar margem para erros.

Existe uma forma de fazer essa operação com apenas um único CTRL+V, considerando que o objetivo seja de colar no mesmo local em todas as planilhas ao mesmo tempo, vejamos como isso funciona.

Dr. Planilha: Como Transpor uma Tabela como Vínculo no #Excel

Vou mostrar hoje como resolver um probleminha bem chato quando queremos criar uma cópia de uma tabela que está em um determinado formato de coluna x linha, para um outro formato de coluna linha,  colando como vínculos.

Vejamos esse exemplo:

Copiar disso:

Para isso (como vínculo):

Dr. Planilha: Calendário Infinito ou Plurianual no #Excel

Disponibilizo aos leitores uma planilha que é um calendário definitivo, ou seja, ano que vêm você poderá usar o mesmo calendário.

Este calendário já calcula automaticamente os feriados básicos e permite que você possa adicionar novos feriados personalizados, como estaduais, municipais e outros feriados facultativos. A seguir explico como adicionar esses feriados ao seu calendário.