sábado, 26 de maio de 2012

Dr. Planilha: Como Fazer Cálculo do IMC no #Excel

Antes de mais nada, vamos entender melhor o que é IMC, emprestando a definição da wikipédia:
O índice de massa corporal (IMC) é uma medida internacional usada para calcular se uma pessoa está no peso ideal.
Ele foi desenvolvido pelo polímata Lambert Quételet no fim do século XIX. Trata-se de um método fácil e rápido para a avaliação do nível de gordura de cada pessoa, ou seja, é um preditor internacional de obesidade adotado pela Organização Mundial da Saúde (OMS).
A fórmula para calcular o IMC é bastante simples, vamos precisar apenas de duas informações, seu Peso em quilogramas e sua Altura em metros. O cálculo consiste em dividir seu peso pela sua altura ao quadrado. Vejamos como ficaria:

Ora, isso parece bastante fácil de se fazer no Excel, e de fato é. Vamos à prática! Para começar, faça uma planilha igual à do exemplo abaixo.

Agora preencheremos a fórmula para o cálculo na célula B3, ela deve ficar da seguinte forma:

=B1/B2^2

Para entender entender melhor a fórmula:
  • B1 = Peso
  • B2 = Altura
  • ^2 = Elevando Altura ao quadrado, se fosse ao cubo seria ^3.
Hm, mas você deve ter percebido uma coisa feia aqui, veja o resultado da nossa fórmula:

O que aconteceu é resultado de uma premissa básica da matemática, nenhum valor pode ser dividido por zero e, como a célula da Altura está vazia, o Excel realiza o cálculo como se fosse dividir por zero. Há formas de se ignorar esse problema através de uma função chamada ÉERROS, conforme descrevo no artigo Como Ocultar Erros em uma Fórmula do #Excel #dica.

Façamos um teste então? Vou preencher com alguns valores fictícios e vejamos o resultado.

Uma pessoa pesando 90 kg e medindo 1,89 mt terá um Índice de Massa Corporal de 27,78. Possivelmente seus valores de IMC possam ter sido apresentados com mais de duas casas decimais, no meu exemplo está com duas por que configurei previamente as células B2 e B3 desta forma.

Vamos adicionar agora uma tabela ao lado do cálculo para que seja possível visualizar em que faixa nosso indivíduo se encontra.

Está pronta nossa planilha que calcula IMC. Em outra ocasião adicionarei uma funcionalidade interessante à essa planilha, uma legenda que mostra automaticamente em que faixa nosso IMC calculado ficou. Não farei hoje porque antes precisamos entender como usar a função SE encadeada, o que pode ser meio confuso para uma boa parte dos visitantes.

Se você tem algum tipo de cálculo que gostaria de ver o Dr. Planilha implementando, use o espaço dos comentários abaixo e deixe sua sugestão. Atenderei todos os pedidos na medida do possível.

=== ATUALIZAÇÃO EM 06/04/2013 ===

Depois que esse artigo foi publicado, vários leitores solicitaram a implementação da identificação automática e, conforme havia prometido, hoje explicarei como implementar essa melhoria.

Como havia dito no artigo original, a identificação automática da faixa do IMC será criada utilizando uma fórmula com a função SE() encadeada para mostrar um indicador na coluna C apontando qual a faixa na qual o IMC calculado se enquadrou.

PASSO 1: Ajustar a tabela de faixas de IMC
Adicionaremos uma coluna nova em branco entre a D e a E e modificaremos a faixa de valores de forma que na coluna D teremos o limite inferior da respectiva faixa de valor e na coluna E o limite superior. Veja o resultado na imagem abaixo:

Agora com as faixas de valores bem definidas, poderemos implementar a função que identificará a classificação correta.

PASSO 2: Identificar a classificação
1. Na célula F9 adicionaremos uma fórmula contendo uma cadeia contendo a função SE() encadeada. Vejamos como ela funciona, lembrando que na célula B3 temos o resultado do índice calculado. Quebrei a fórmula em linhas e adicionei uma identação para facilitar a visualização de como o cálculo é realizado.

=SE(B3<E2;F2;SE(B3<=E3;F3;SE(B3<=E4;F4;SE(B3<=E5;F5;SE(B3<=E6;F6;F7)))))

Fórmula quebrada em linhas

SE(B3<=E2;F2; <<== Se B3 menor ou igual a 18,5 = "Abaixo do peso", SENÃO
  SE(B3<=E3;F3; <<== Se B3 menor do que 24,9 = "Saudável", SENÃO
    SE(B3<=E4;F4; <<== Se B3 menor do que 29,9 = "Peso em excesso", SENÃO
      SE(B3<=E5;F5; <<== Se B3 menor do que 34,9 = "Obesidade Grau I", SENÃO
        SE(B3<=E6;F6; <<== Se B3 menor do que 24,9 = "Obesidade Grau II (severa)", SENÃO
          F7))))) <<== Se B3 menor do que 24,9 = "Obesidade Grau II (severa)"

Aqui podemos ver que nessa fórmula com SE() encadeado o Excel começará a resolver o problema da esquerda para a direita, ou seja, se a condição testada que está mais à esquerda for verdadeira, será mostrado a classificação daquela faixa testada, caso contrário, partirá para o próximo teste mais à direita.

PASSO 3: Adicionar uma seta indicadora 
1. Incrementaremos nossa planilha com mais uma indicação, agora que temos na célula F9 a descrição da classificação na qual o IMC se enquadrou. Na célula C2 adicionaremos uma fórmula para mostrar uma seta na linha da classificação identificada, conforme podemos ver abaixo.

=SE($F$9=F2;"==>";"")

Significa dizer que se o texto apresentado na célula F9 for igual ao texto da célula F2, mostraremos uma seta indicando que é aquela classificação.

2. Agora copiaremos essa fórmula para baixo até a célula C7 para contemplar as demais classificações. O resultado final será algo como podemos ver na imagem abaixo.


Abaixo segue o link para download da planilha modificada que foi utilizada no artigo, nas versões do Excel 2003 e Excel 2007/2010.

Excel 2003
Excel 2007/2010

Um grande abraço do Dr. Planilha!

Related Posts Plugin for WordPress, Blogger...