domingo, 6 de maio de 2012

Dúvida do Leitor - Como Testar Faixas de Valor no #Excel Usando a fórmula SE? #dúvida #dica

PERGUNTA
Prezado Dr Planilha, boa noite! Usei a seguinte fórmula em uma planilha: =SE(F6<18,5;"Desnutrição";SE(F6>=18,5;"Eutrofia";SE(F6>24,9;"Sobrepeso";SE(F6>29,9;"Obesidade GI";SE(F6>34,9;"Obesidade GII";SE(F6>40;"Obesidade GIII"))))))
No entanto, só me retornam dois resultados (Desnutrição e Eutrofia), mas as colunas "F" tem valores que se
classificam desde "Desnutrição" até "Obesidade GIII". O que eu fiz de errado? Pode me ajudar? Grata, Elaine

RESPOSTA
Olá Elaine, é um prazer tê-la aqui no Blog do Dr. Planilha!

Após fazer um raio-x na sua fórmula encontrei alguns probleminhas de lógica, mas feitas as devidas correções, parece que agora está tudo funcionando.

Estudando sua fórmula deduzi que estamos trabalhando com as seguintes faixas de valores:
  • Desnutrição: 0 a 18,49
  • Eutrofia: 18,5 a 24,89
  • Sobrepeso: 24,9 a 29,89
  • Obesidade GI: 29,9 a 34,89
  • Obesidade GII: 34,9 a 39,99
  • Obesidade GIII: 40 a ...
Sua fórmula fica da seguinte forma:

=SE(F6<18,5;"Desnutrição";SE(F6<24,9;"Eutrofia";SE(F6<29,9;"Sobrepeso";SE(F6<34,9;"Obesidade GI";SE(F6<40;"Obesidade GII";"Obesidade GIII")))))

Observe que na nova fórmula não foram testados os limites inferiores, só os superiores, o que simplificou a fórmula e pudemos usar só o "<" e nenhum "=". O que simplificou também é o fato de que fiz um novo teste para a opção "Obesidade GIII", pois se não é nenhum dos valores anteriores, só resta o "Obesidade GIII" que vai de 40 ao infinito.

Para facilitar na compreensão do uso da fórmula SE intercalada, como é o nosso caso, abaixo segue um teste de mesa para cada situação para entendermos como o Excel resolve esse problema.

PRIMEIRO EXEMPLO
Valor informado: 20
TESTE 1: É menor do que 18,5? NÃO
TESTE 2: É menor do que 24,9? SIM
ENTÃO ---> Apresenta o texto "Eutrofia"

SEGUNDO EXEMPLO
Valor informado: 42
TESTE 1: É menor do que 18,5? NÃO
TESTE 2: É menor do que 24,9? NÃO

TESTE 3: É menor do que 29,9? NÃO
TESTE 4: É menor do que 34,9? NÃO
TESTE 5: É menor do que 40?    NÃO
ENTÃO --> Apresenta o texto "Obesidade GIII"

TERCEIRO EXEMPLO
Valor informado: 27
TESTE 1: É menor do que 18,5? NÃO
TESTE 2: É menor do que 24,9? NÃO

TESTE 3: É menor do que 29,9? SIM
 ---> Apresenta o texto "Sobrepeso"

Segue o link caso queira salvar no seu computador a planilha que usei como teste.
Exemplo Teste Faixas de Valor.xlsx

Espero que isso resolva a sua dúvida.

Um grande abraço do Dr. Planilha!

3 comentários:

  1. Mais doutor planilha, acompanhei seu exemplo ali,
    imaginando q a pessoa pese 2kg ele entraria em todas condições, como resolver?

    ResponderExcluir
  2. Bom dia!
    Dr planilha estou tentando a vários dias fazer uma formula que me retorna o valor(135), caso meu resultado seja entre(>0<=100), estou usando esta formula, =SE(G4>0;"135";SE(G4<=100;"0")). e não está dando certo, quando o resultado é (0) da certo poque é falso, mas quando da acima de (100), ela me retorna o valor(135), e o que seria serto é da (falso), onde estou errando? se possivel por favor me ajude.
    Obrigado Julio.

    ResponderExcluir
  3. Olá bom dia!
    Venho em busca de uma solução para um problema caso possa me ajudar ou indicar um técnico nda microsft possa, montar e qual formula usar atendendo estes critérios abaixo mencinados pois ate agora não tive êxito ne mesmo nas comunidades e forun se puder me ajudar ficarei grato,
    Desde já agradeço

    At.
    Marcelo R



    Preciso localizar e copiar simultaneamente somente as terceira célula que esta embaixo de todas quando for idêntica A1.

    Sempre que a coluna A tiver célula igual a A1 localizar e copiar a terceira célula que esta embaixo.

    Quando for idêntica a A1 localizar e copiar a terceira celula que esta embaixo



    A

    2
    25
    55
    33
    2
    66
    44
    77
    2
    88
    99
    22
    2
    31
    32
    68
    2
    97
    54
    79
    2
    45
    69
    75
    2
    57
    26
    2
    2
    15
    17
    18
    2
    87
    568
    2
    597

    ResponderExcluir

Use esse espaço para enviar suas dúvidas ou fazer críticas e sugestões. Todos os comentários serão postados após passarem pela moderação do Dr. Planilha para que seja mantido o alto nível do conteúdo do blog.

Related Posts Plugin for WordPress, Blogger...