Pular para o conteúdo principal

Postagens

Mostrando postagens de Agosto, 2016

Dr. Planilha: Como Ocultar Erros em uma Fórmula do #Excel #dica (versão 2)

Há algum tempo atrás postei uma dica de como resolver esse problema utilizando as funções ÉERROS() e SE() (veja aqui). Funciona muito bem, mas se você procura algo mais simples de escrever e ler, a função SEERRO() pode ser uma alternativa mais interessante.

Antes de mais nada, vejamos qual a sintaxe dessa função:

SEERRO(valor; valor_se_erro)

Ao que se pode perceber imediatamente é que seu funcionamento é muito simples, basicamente ela implementa a solução que apresentei no artigo anterior, com a diferença de termos apenas uma função e dois parâmetros.

O parâmetro "valor" deverá ser preenchido com a fórmula que você pretende mostrar na célula, por exemplo: A1/A2.

O parâmetro "valor_se_erro" é o que você irá preencher na célula, caso sua fórmula resulte em um erro, como em uma divisão por zero. Em nosso exemplo eu poderia colocar o valor 0 (zero).

A função preenchida ficaria assim:

=SEERRO(A1/A2;0)

Ou se eu quisesse mostrar uma mensagem alertando do erro:

=SEERRO(A1/…