Pular para o conteúdo principal

Dr. Planilha: Como Ocultar Erros em uma Fórmula do #Excel #dica (versão 2)

Há algum tempo atrás postei uma dica de como resolver esse problema utilizando as funções ÉERROS() e SE() (veja aqui). Funciona muito bem, mas se você procura algo mais simples de escrever e ler, a função SEERRO() pode ser uma alternativa mais interessante.

Antes de mais nada, vejamos qual a sintaxe dessa função:

SEERRO(valor; valor_se_erro)

Ao que se pode perceber imediatamente é que seu funcionamento é muito simples, basicamente ela implementa a solução que apresentei no artigo anterior, com a diferença de termos apenas uma função e dois parâmetros.

O parâmetro "valor" deverá ser preenchido com a fórmula que você pretende mostrar na célula, por exemplo: A1/A2.

O parâmetro "valor_se_erro" é o que você irá preencher na célula, caso sua fórmula resulte em um erro, como em uma divisão por zero. Em nosso exemplo eu poderia colocar o valor 0 (zero).

A função preenchida ficaria assim:

=SEERRO(A1/A2;0)

Ou se eu quisesse mostrar uma mensagem alertando do erro:

=SEERRO(A1/A2;"Divisão por ZERO")

Convenhamos, muito mais simples do que o SE() combinado ao ÉERROS(), rs rs rs.

Meu conselho é que você use e abuse desse tipo de recurso em situações que provocam erros de fórmula, pois seu trabalho ficará muito mais elegante e profissional, evitando erros em gráficos e relatórios finais e garantindo a consistência das informações.

Essa função foi implementada a partir do Excel 2007, as versões anteriores não possuem esse recurso.

Um grande abraço do Dr. Planilha!

Comentários

Postagens mais visitadas deste blog

Dr. Planilha: Como Remover Linhas de Grade no #Excel #dica

As linhas de grade do Excel não aparecerão em relatórios impressos, mas pode ser que você também deseje que elas fiquem ocultas quando estiver trabalhando com a planilha por uma questão de estética ou

Antes de mais nada é importante ainda que se diga que "linha de grade" não é a mesma coisa que "borda".

Dr. Planilha: Como Fazer Cálculo do IMC no #Excel

Antes de mais nada, vamos entender melhor o que é IMC, emprestando a definição da wikipédia:
O índice de massa corporal (IMC) é uma medida internacional usada para calcular se uma pessoa está no peso ideal.Ele foi desenvolvido pelo polímata Lambert Quételet no fim do século XIX. Trata-se de um método fácil e rápido para a avaliação do nível de gordura de cada pessoa, ou seja, é um preditor internacional de obesidade adotado pela Organização Mundial da Saúde (OMS). A fórmula para calcular o IMC é bastante simples, vamos precisar apenas de duas informações, seu Peso em quilogramas e sua Altura em metros. O cálculo consiste em dividir seu peso pela sua altura ao quadrado. Vejamos como ficaria:

Ora, isso parece bastante fácil de se fazer no Excel, e de fato é. Vamos à prática! Para começar, faça uma planilha igual à do exemplo abaixo.

Agora preencheremos a fórmula para o cálculo na célula B3, ela deve ficar da seguinte forma:

=B1/B2^2

Para entender entender melhor a fórmula:
B1 = PesoB2 = Al…

Dr. Planilha: Como Colar Valores Horizontais na Vertical e Vice-Versa no #Excel

Olá pessoal!

Trouxe uma dica rápida para vocês que ajuda muito no dia-a-dia e sei que muitas pessoas a desconhecem: colar valores com transposição da horizontal para a vertical ou da vertical para a horizontal.

Para explicar, vamos a um exemplo comum do quotidiano de quem trabalha com planilhas:

O departamento financeiro fornece à área de marketing um relatório com o valor total das vendas por vendedor, distribuído da seguinte forma:

O problema é que no relatório da área de marketing essas informações não estão distribuídas em colunas, mas sim, em linhas. Como resolver isso com o menor trabalho possível? Veremos a seguir.